Shadowsocks 一键安装脚本




一键安装 Shadowsocks-Python, ShadowsocksR, Shadowsocks-Go, Shadowsocks-libev 版(四选一)服务端

脚本适用环境

系统支持:CentOS 6+,Debian 7+,Ubuntu 12+
内存要求:≥128M

使用root用户登录,运行以下命令:
   服务器端口:自己设定(如不设定,默认从 9000-19999 之间随机生成)
   密码:自己设定(如不设定,默认为 teddysun.com)
   加密方式:自己设定(如不设定,Python 和 libev 版默认为 aes-256-gcm,R 和 Go 版默认为 aes-256-cfb)
   协议(protocol):自己设定(如不设定,默认为 origin)(仅限 ShadowsocksR 版)
   混淆(obfs):自己设定(如不设定,默认为 plain)(仅限 ShadowsocksR 版)
   备注:脚本默认创建单用户配置文件,如需配置多用户,请手动修改相应的配置文件后重启即可。
使用root用户登录,运行以下命令:
使用root用户登录,运行以下命令:
1.wget --no-check-certificate -O shadowsocks-all.sh https://raw.githubusercontent.com/teddysun/shadowsocks_install/master/shadowsocks-all.sh
2.chmod +x shadowsocks-all.sh
3../shadowsocks-all.sh 2>&1 | tee shadowsocks-all.log


评论

此博客中的热门博文